1с как определить текущего пользователя программно
Перейти к содержимому

1с как определить текущего пользователя программно

  • автор:

1С 8.3 Пользователи, роли (права) доступа — Программист 1С Минск. Автоматизация бизнеса.

✔ Создать, удалить пользователя, вывести список

ПользовательИБ = ПользователиИнформационнойБазы . СоздатьПользователя ();
ПользовательИБ . Имя = «Лев Толстой» ;
ПользовательИБ . Пароль = «Wp1865» ;
ПользовательИБ . ПоказыватьВСпискеВыбора = Истина;
ПользовательИБ . Роли . Добавить ( Метаданные . Роли . АдминистраторСистемы );
ПользовательИБ . ОсновнойИнтерфейс = Метаданные . Интерфейсы . Основной ;
ПользовательИБ . Записать ();

ПользовательИБ = ПользователиИнформационнойБазы . НайтиПоИмени ( «Лев Толстой» );
ПользовательИБ . Удалить ();

//ПользовательИБ = ПользователиИнформационнойБазы.ТекущийПользователь();
//ПользовательИБ.Удалить();

СписокПользователей = ПользователиИнформационнойБазы . ПолучитьПользователей ();
Для Каждого ПользовательИБ Из СписокПользователей Цикл
Сообщить ( ПользовательИБ );
КонецЦикла;

&НаКлиенте
Процедура БлокировкаРаботыПользователя ( Команда )

&НаКлиенте
Процедура ПолучениеИмениТекущегоПользователя ( Команда )

Полученное_Имя = ИмяПользователя (); // Морозов А.И.
Полученное_Имя_Полное = ПолноеИмяПользователя (); // Морозов Александр Иванович

&НаСервере
Процедура ЧтениеИПроверкаПравИРолейПользователей () // Варианты прав: Чтение, Изменение, Добавление, Удаление, Проведение

// Чтение права к объекту метаданных у текущего пользователя
Если ПравоДоступа ( «Изменение» , Метаданные . Справочники . Материалы ) Тогда
Сообщить ( «Доступ к справочнику Материалы на изменение открыт!» );
КонецЕсли;

// Чтение права к объекту метаданных у определенной роли
Если Не ПравоДоступа ( «Удаление» , Метаданные . Справочники . Материалы , Метаданные . Роли . Менеджер ) Тогда
Сообщить ( «У роли Менеджер нет прав на удаление в справочнике Материалы!» );
КонецЕсли;

// Проверка права к объекту метаданных у других пользователей
ВсеПользователи = ПользователиИнформационнойБазы . ПолучитьПользователей ();
Для Каждого Пользователь Из ВсеПользователи Цикл
Если ПравоДоступа ( «Изменение» , Метаданные . Справочники . Материалы , Пользователь ) Тогда
Сообщить ( «Доступ для » + Пользователь . Имя + » на изменение открыт!» );
КонецЕсли;
КонецЦикла;

// Чтение роли у текущего пользователя
Если РольДоступна ( «Администратор» ) Тогда
Сообщить ( «У Вас права Администратора!» );
КонецЕсли;

// Проверка права у пользователя и в случае его отсутствия — вызов исключения
ВыполнитьПроверкуПравДоступа ( «Изменение» , Метаданные . Справочники . Материалы ); // «Нарушение прав доступа!»

&НаСервере
Процедура СохранениеЧтениеУдалениеНастроекПользователя ()

// Сохранение произвольных настроек конкретного пользователя
НастройкиПользователя = Новый Структура ;
НастройкиПользователя . Вставить ( «Фамилия» , «Дарк» );
НастройкиПользователя . Вставить ( «Имя» , «Жанна» );
НастройкиПользователя . Вставить ( «Пол» , «Ж» );
НастройкиПользователя . Вставить ( «Возраст» , 19 );

// Параметры: Ключ объекта, Ключ настроек, Настройки, Описание настроек, Владелец настроек,
ХранилищеОбщихНастроек . Сохранить ( «Отчет.ОСВ» , «КлючНастроек» , НастройкиПользователя , , ИмяПользователя ());

// Сохранение произвольных настроек для всех пользователей
ВсеПользователи = ПользователиИнформационнойБазы . ПолучитьПользователей ();
Для Каждого Пользователь Из ВсеПользователи Цикл
ХранилищеОбщихНастроек . Сохранить ( «Отчет.ОСВ» , «КлючНастроек» , НастройкиПользователя , , Пользователь . Имя );
КонецЦикла;

// Чтение сохраненных настроек пользователя
ЧтениеНастроек = Неопределено;
Попытка
ЧтениеНастроек = ХранилищеОбщихНастроек . Загрузить ( «Отчет.ОСВ» , «КлючНастроек» ,, ИмяПользователя ());
Исключение
Сообщить ( «Не достаточно прав доступа к настройкам пользователя: » + ИмяПользователя ());
КонецПопытки;

Если ЧтениеНастроек = Неопределено Тогда // Значит настроек нет
Сообщить ( «Не получилось прочитать настройки.» );
Иначе // Чтение настроек
Сообщить ( «Имя:» + ЧтениеНастроек . Имя + «; Фамилия:» + ЧтениеНастроек . Фамилия +
«; Пол:» + ЧтениеНастроек . Пол + «; Возраст:» + ЧтениеНастроек . Возраст );
КонецЕсли;

// Удаление сохраненных настроек пользователя
ХранилищеОбщихНастроек . Удалить ( «Отчет.ОСВ» , «КлючНастроек» , ИмяПользователя ());

// Удаление сохраненных настроек у всех пользователей
ХранилищеОбщихНастроек . Удалить ( «Отчет.ОСВ» , «КлючНастроек» , Неопределено);

Как получить пользователя ИБ в 1С

Ребят, как можно получить пользователя информационной базы 1С? Это же не справочник в конфигурации. У меня есть только Пользователь, подскажите как решить такую проблему!

У элемента справочника Пользователи есть идентификатор пользователя ИБ, по нему и можно получить пользователя информационной базы.

Пример для текущего пользователя:

  • Создание внешней печатной формы для управляемого приложения в 1С 8.3
  • Получение уникального идентификатора из ссылки 1С
  • Параметры и ключи запуска в 1С 8.3 и 8.2
  • Настройка двухстороннего обмена данными между конфигурациями «Управление торговлей 10.3» и «Бухгалтерия предприятия 2.0» в 1С 8

Подпишитесь на наш YouTube канал

Связаться с нами можно по телефону:

Наша команда предоставляет услуги по консультированию, настройке и внедрению 1С.

Услуги и цены можно увидеть по ссылке.

Будем рады помочь Вам!

Свежие записи

  • Как выгрузить базу из 1С 8.3 на флешку
  • Поиск и удаление дублей в 1С 8.3
  • Настройка 1С ЗУП 8.3 — пошаговая инструкция
  • Зарплатный проект в 1С 8.3 Бухгалтерия
  • Оказание услуг в 1С 8.3 — пошаговая инструкция
  • Как сделать договор в 1С 8.3: шаблоны договоров

Подписывайтесь на наш YouTube канал, чтобы узнать больше о 1С. Там вы найдете множество видео-уроков. Ждем вас!

При использовании данного сайта, вы подтверждаете свое согласие на использование файлов cookie в соответствии с настоящим уведомлением в отношении данного типа файлов. Если вы не согласны с тем, чтобы мы использовали данный тип файлов, то вы должны соответствующим образом установить настройки вашего браузера или не использовать сайт

Группы пользователей 1с программное получение

Группы пользователей 1с используются для разделения доступа, например к организациям. Рассмотрим примеры их получения в двух конфигурациях.

Получить группы пользователей 1с в Бухгалтерии 2.0

В конфигурации Бухгалтерия 2.0 можно воспользоваться типовой функцией ГруппыПользователя(<Пользователь>), из модуля УправлениеПользователями.

Пример 1. Получим все группы текущего пользователя.

Получить группы пользователей 1с в Управлении торговлей 11

В конфигурации Управление торговлей 11.1 можно использовать следующую функцию:

Эту функцию можно расположить в вашем, не типовом, серверном общем модуле и использовать по мере надобности.

Пример 2. Проверить, принадлежит ли текущий пользователь 1с группе пользователей Розничные продажи (код для серверной процедуры)

Добавить комментарий

Ваш адрес email не будет опубликован.