1с как удалить настройки пользователя
Перейти к содержимому

1с как удалить настройки пользователя

  • автор:

Настройки пользователей

Предназначен для управления пользовательскими настройками.

В списке можно производить просмотр, очистку и копирование пользовательских настроек отчетов, настроек внешнего вида программы и прочих настроек.

Список настроек можно открыть из раздела Администрирование — Настройки пользователей и прав по команде Настройки пользователей.

  • В этом случае в списке имеется поле Пользователь. По умолчанию поле Пользователь заполнено значением Администратор, при этом поле не может быть пустым. При этом если в программе имеются внешние пользователи, то можно управлять и их настройками.

Также список настроек каждого пользователя (внешнего пользователя) можно открыть по команде Настройки панели навигации.

  • В этом случае поле Пользователь отсутствует.

Можно выполнить поиск, введя в поле «Найти» название или часть названия необходимой настройки.

Список состоит из трех вкладок:

  • Внешний вид — выводятся настройки внешнего вида рабочего стола, форм (например, различных списков программы) и командного интерфейса программы.
  • Настройки отчетов — список пользовательских настроек отчетов сгруппирован по названиям вариантов отчетов.
  • Прочие настройки — выводятся персональные настройки пользователя, настройки печати табличного документа, настройки быстрого доступа к дополнительным отчетам и обработкам, настройки раздела Избранное и прочие настройки.

Копирование настроек

В поле Пользователь выберите нужного пользователя. Возможны действия:

Ограничения

Не все пользовательские настройки можно скопировать, даже если был нажат переключатель Все настройки.

В таких случаях программа выдает предупреждение, что не все настройки были скопированы. Нажмите кнопку Показать отчет для того чтобы посмотреть, какие настройки были пропущены при копировании.

Очистка настроек выбранного пользователя

В поле Пользователь выберите нужного пользователя. Возможны действия:

Персональные настройки пользователей: копирование и очистка настроек, в Бухгалтерии предприятия 3.0.

Чтобы начать работу с персональными настройками пользователей заходим в раздел “Настройки пользователей и прав” (Администрирование/Настройки пользователей и прав).

nastroikapolprav.jpg

Рис. 1. Настройки пользователей и прав.

Далее выбираем “Копирование настроек” (Персональные настройки пользователей/Копирование настроек)

KopirNastroik.jpg

Рис. 2. Копирование настроек.

Открывается окно “Копирование настроек пользователей”. Здесь соответственно мы можем выбрать:
1) От какого пользователя мы можем скопировать настройки;

2) Какому пользователю мы можем скопировать настройки;

3) Какие настройки мы можем скопировать.

KopirnastrPol.jpg

Рис.3. Копирование настроек пользователей.

viborpolz.jpg

Рис.4. Выбор пользователя.

viborpolzdlykopir.jpg

Рис.5. Выбор пользователей для копирования настроек.

vibornastroikpolz.jpg

Рис. 6. Выбор настроек пользователя.

После того, как выбрали все необходимые данные, нажимаем “Скопировать и закрыть” или “Скопировать”, после чего в углу появится окно, информирующее нас о том, что настройки скопированы.

kopirnsatpolz.jpg

Рис. 7. Копирование настроек пользователей.

itogkopir.jpg

Рис. 8. Итог копирования.

При очистке настроек так же необходимо выбрать:

1. Какому пользователю мы можем очистить настройки;

2. Какие настройки мы можем очистить.

ochistkanastroik.jpg

Рис. 9. Очистка настроек пользователей.

Выбрав необходимые данные, мы нажимаем “Очистить и закрыть” или “Очистить”, после чего в углу появится окно, информирующее нас о том, что настройки очищены.

1С 8.3 Сбросить настройки пользователя — Программист 1С Минск. Автоматизация бизнеса.

Если Пользователь . Метаданные (). Реквизиты . Найти ( «ИдентификаторПользователяИБ» ) <> Неопределено Тогда
ПользовательИБ = ПользователиИнформационнойБазы . НайтиПоУникальномуИдентификатору ( Пользователь . ИдентификаторПользователяИБ );
Иначе
ПользовательИБ = ПользователиИнформационнойБазы . НайтиПоИмени ( СокрЛП ( Пользователь . Код ));
КонецЕсли;

ХранилищеНастроек = Вычислить ( «ХранилищеВариантовОтчетов» );
//ХранилищеНастроек = Вычислить(«ХранилищеНастроекДанныхФорм»);
//ХранилищеНастроек = Вычислить(«ХранилищеОбщихНастроек»);
//ХранилищеНастроек = Вычислить(«ХранилищеПользовательскихНастроекДинамическихСписков»);
//ХранилищеНастроек = Вычислить(«ХранилищеПользовательскихНастроекОтчетов»);
//ХранилищеНастроек = Вычислить(«ХранилищеСистемныхНастроек»);

#Если ТолстыйКлиент Тогда
ОчиститьНастройкиПользователя ( ПользовательИБ );
#Иначе
ОчиститьНастройкиПользователяВХранилище ( ХранилищеНастроек . Имя , ПользовательИБ );
#КонецЕсли

Процедура ОчиститьНастройкиПользователяВХранилище ( ХранилищеВО , ПользовательИБ )

Если Ложь Тогда
ХранилищеВО = ХранилищеВариантовОтчетов ;
ПользовательИБ = ПользователиИнформационнойБазы . НайтиПоИмени ( «» );
КонецЕсли;

ОтборП = Новый Структура ;
ОтборП . Вставить ( «Пользователь» , ПользовательИБ . Имя );

Попытка
ВыборкаХВО = ХранилищеВО . Выбрать ( ОтборП );
Исключение
Сообщить ( ХранилищеВО );
Возврат;
КонецПопытки;

Пока ВыборкаХВО . Следующий () Цикл
ХранилищеВО . Удалить ( ВыборкаХВО . КлючОбъекта , ВыборкаХВО . КлючНастроек , ВыборкаХВО . Пользователь );
Сообщить ( «Удалено: » + ВыборкаХВО . КлючОбъекта + «, » + ВыборкаХВО . КлючНастроек + «, » + ВыборкаХВО . Пользователь );
КонецЦикла;

Добавить комментарий

Ваш адрес email не будет опубликован.